0.614 + 'possible corrupt cookie'

CaMer0n by CaMer0n in e107

I know that many, may people have been getting the 'possible corrupt cookie' error after upgrading to 0.614, I finally sat down yesterday to see what the problem was.

I know that many, may people have been getting the 'possible corrupt cookie' error after upgrading to 0.614, I finally sat down yesterday to see what the problem was.

This is caused by sites using a non-standard login_menu (ie clean login). It seems that a small piece of the cookie code what changed in the interest of security. The core login_menu was changed to accomodate this, but the others were no (obviously).

All sites using the alternate login menus will have to revert back to the original login menu until these others are updated to reflect this change.

If the authors of the plugins want to contact me I will explain exactly what needs done. The change is actually removing a db lookup.

Sorry for any confusion.





This news item is from e107 v2 Bootstrap CMS
https://e107.org/blog/526.html